박상권의 삽질블로그

Android N requires the IDE to be running with Java 1.8 or later 본문

IT/Android-ERROR&SOLVE

Android N requires the IDE to be running with Java 1.8 or later

박상권 2016.06.30 23:41

Android N requires the IDE to be running with Java 1.8 or later


안드로이드 API 24 로 업데이트 하면 xml의 Preview에서 위와같은 오류메세지가 나타납니다.

이미 JDK는 1.8버전으로 깔려 있는데도 자꾸 1.8이상으로 설치하라고만 나옵니다.


간단하게 xml에서 기준 api버전을 23이하로 변경하면 바로 나오긴 하지만 여전히 거슬립니다.


아직 정확한 이유를 알수는 없지만 이렇게하면 정상적으로 해결되긴 합니다.


안드로이드의 Info.plist 파일을 수정하면 됩니다.

OX X의 경우 Android Studio.app에서 [패키지보기]를 선택한뒤 Contents폴더 아래에서 Info.plist파일을 찾아볼수 있다.(/Applications/Android\ Studio.app/Contents/Info.plist)


파일 내용중 아래 JVMVersion key를 찾습니다.


...
<key>JVMVersion</key>
<string>1.6+,1.7+</string>
...


이부분에서 1.6+ 를 지우고 저장하면 거짓말처럼 해결됩니다.

발생원인과 해결되는 이유는 추후에 자세하게 분석후 추가하겠습니다.


2 Comments
  • BlogIcon ZeroFlag 2016.07.29 12:05 신고 안녕하세요 같은증상으로 이리저리 검색하다가 들린 사람입니다.

    다름이 아니라 말씀해주신 방법으로 설정하여 1.6*+1.7+되어있는부분중

    1.7+를 남기고 삭제하였습니다 보여주신것처럼 워드파일로 열리지않고 xcode로 열었다는게 다른점이라면 다르겠네요

    그런데 아직 해결이되고있질 않습니다;;

    무언가 다른방법이 있을까요? 질문드려봅니다.
  • BlogIcon 박상권 2016.08.11 08:53 신고 안녕하세요
    실제로 1.7이 설치되어 있으신가요?
댓글쓰기 폼